Resolved
The performance issue has been resolved, and all services are operating normally. Currently the following actions/pages will be unavailable: Prior Authorizations Reports Page and Prior Authorizations Reports Download Functionality
Monitoring
Mitigations have been applied and performance is improving. We are monitoring system behavior to confirm full recovery.
Currently the following actions/pages will be unavailable: Prior Authorizations Reports Page and Prior Authorizations Reports Download Functionality
Resolved
Mitigations have been applied and performance is improving. We are monitoring system behavior to confirm full recovery.
Currently the following actions/pages will be unavailable: Prior Authorizations Reports Page and Prior Authorizations Reports Download Functionality
Monitoring
Mitigations have been applied and performance is improving. We are monitoring system behavior to confirm full recovery.