Resolved
The service disruption issue has been fully resolved, and all impacted services are functioning normally.
Investigating
Users navigating to the legacy Appointments page are seeing an error and unable to load the page. Please use the New Appointments page in the meantime: https://insights.athelas.com/appointments